Maintenance completed
Incident Report for Mapillary
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 12, 2018 - 20:03 CET
Investigating
The maintenance work is now completed, things are back to normal.

Thanks for your patience!
Posted 4 months ago. Mar 12, 2018 - 13:29 CET